WordPress Update 4.1.2 – Critical Security Update

WordPress Critical Security Update WordPress issued a critical security update to version 4.1.* – the newest version is 4.1.2. ¬†This addresses unsafe and invalid file names that could previously be uploaded in version 4.1.1. And “…a very limited cross-site scripting vulnerability could be used as part of a social engineering attack” in versions 3.9 and […]

WordPress Brute Force Attacks and Security Best Practices

WordPress Security Best Practices against Brute Force Attacks and Hacking There is a current security/performance risk for all WordPress blogs. There are a large number of WordPress “brute force attacks” and hacking happening that are both hacking into WordPress web sites and also causing DOS (Denial of Service) to many sites, even if they are […]